This repository has been archived on 2023-12-26. You can view files and clone it, but cannot push or open issues or pull requests.
hypervisors/flake.nix
Pim Kunis 701be696fe add data pool for atlas
add nix flake for development environment
pin TF libvirt provider because of SSH issue
explicitly pass known hosts file to libvirt connection string
2023-10-26 16:24:25 +02:00

18 lines
482 B
Nix

{
description = "A basic flake with a shell";
inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
inputs.flake-utils.url = "github:numtide/flake-utils";
outputs = { self, nixpkgs, flake-utils }:
flake-utils.lib.eachDefaultSystem (system: let
pkgs = nixpkgs.legacyPackages.${system};
in {
devShells.default = pkgs.mkShell {
packages = with pkgs; [
bashInteractive
opentofu
jq
];
};
});
}