27 lines
607 B
Nix
27 lines
607 B
Nix
{
|
|
config,
|
|
pkgs,
|
|
...
|
|
}: {
|
|
imports = [./jellyseerr-module.nix];
|
|
|
|
disabledModules = ["services/misc/jellyseerr.nix"];
|
|
|
|
config = {
|
|
facter.reportPath = ./facter.json;
|
|
system.stateVersion = "23.05";
|
|
users.users.root.openssh.authorizedKeys.keys = config.pim.ssh.keys.pim ++ config.pim.ssh.keys.niels;
|
|
pim.k3s.serverAddr = "https://jefke.dmz:6443";
|
|
|
|
deployment = {
|
|
targetHost = "atlas";
|
|
targetUser = "root";
|
|
tags = ["server" "kubernetes"];
|
|
};
|
|
|
|
services.jellyseerr = {
|
|
enable = true;
|
|
package = pkgs.callPackage ./jellyseerr.nix {};
|
|
};
|
|
};
|
|
}
|