14 lines
387 B
Nix
14 lines
387 B
Nix
{config, ...}: {
|
|
config = {
|
|
facter.reportPath = ./facter.json;
|
|
system.stateVersion = "23.05";
|
|
users.users.root.openssh.authorizedKeys.keys = config.pim.ssh.keys.pim ++ config.pim.ssh.keys.niels;
|
|
pim.k3s.serverAddr = "https://jefke.dmz:6443";
|
|
|
|
deployment = {
|
|
targetHost = "atlas";
|
|
targetUser = "root";
|
|
tags = ["server" "kubernetes"];
|
|
};
|
|
};
|
|
}
|