39 lines
865 B
Nix
39 lines
865 B
Nix
{
|
|
lib,
|
|
config,
|
|
inputs,
|
|
...
|
|
}: {
|
|
imports = [inputs.nixos-hardware.nixosModules.raspberry-pi-4];
|
|
|
|
config = {
|
|
pim = {
|
|
tailscale.advertiseExitNode = true;
|
|
prometheus.enable = true;
|
|
};
|
|
|
|
facter.reportPath = ./facter.json;
|
|
system.stateVersion = "23.05";
|
|
|
|
systemd.network.networks."30-main-nic" = {
|
|
matchConfig.Name = lib.mkForce "end*";
|
|
networkConfig.IPv6AcceptRA = true;
|
|
};
|
|
|
|
deployment = {
|
|
targetHost = "warwick";
|
|
targetUser = "root";
|
|
tags = ["server"];
|
|
buildOnTarget = true;
|
|
};
|
|
|
|
boot.loader.systemd-boot.enable = lib.mkForce false;
|
|
users.users.root.openssh.authorizedKeys.keys = config.pim.ssh.keys.pim ++ config.pim.ssh.keys.niels;
|
|
|
|
fileSystems."/" = {
|
|
device = "/dev/disk/by-label/NIXOS_SD";
|
|
fsType = "ext4";
|
|
options = ["noatime"];
|
|
};
|
|
};
|
|
}
|