17 lines
236 B
Nix
17 lines
236 B
Nix
{
|
|
lib,
|
|
config,
|
|
...
|
|
}: {
|
|
imports = [
|
|
./k3s
|
|
./storage.nix
|
|
];
|
|
|
|
config = lib.mkIf (builtins.elem "kubernetes" config.deployment.tags) {
|
|
pim = {
|
|
k3s.enable = true;
|
|
hasK8sStorageSetup = true;
|
|
};
|
|
};
|
|
}
|