This repository has been archived on 2023-10-08. You can view files and clone it, but cannot push or open issues or pull requests.
nixos-home/home.nix

48 lines
679 B
Nix

{ pkgs, ... }:
{
imports = [
./bash
./neovim
./firefox
./ssh
./syncthing
./alacritty
./keepassxc
./git
./direnv
./thunderbird
./fzf
];
home = {
username = "pim";
homeDirectory = "/home/pim";
stateVersion = "23.05";
packages = with pkgs; [
moonlight-qt
vlc
nicotine-plus
logseq
signal-desktop
telegram-desktop
strawberry
tree
gimp
libreoffice
];
};
programs = {
home-manager.enable = true;
chromium.enable = true;
};
# Let home-manager manage the X session
xsession = {
enable = true;
};
xdg.userDirs.enable = true;
}