This repository has been archived on 2023-10-08. You can view files and clone it, but cannot push or open issues or pull requests.
nixos/configuration.nix
2023-10-08 11:04:44 +02:00

70 lines
1.6 KiB
Nix

{ config, pkgs, lib, ... }@args:
let
stateVersion = "23.05";
home-manager = builtins.fetchTarball "https://github.com/nix-community/home-manager/archive/release-${stateVersion}.tar.gz";
in
{
imports =
[
./hardware-configuration.nix
(import "${home-manager}/nixos")
];
boot = {
loader.systemd-boot.enable = true;
kernelParams = [ "i915.enable_psr=0" ];
};
networking.hostName = "x260";
time.timeZone = "Europe/Amsterdam";
i18n.defaultLocale = "en_US.UTF-8";
services.xserver = {
enable = true;
displayManager.gdm = {
enable = true;
};
desktopManager.gnome.enable = true;
excludePackages = with pkgs; [ xterm ];
};
home-manager.users.pim = import /home/pim/.config/home-manager/home.nix;
users.users.pim = {
isNormalUser = true;
extraGroups = [ "wheel" ];
};
environment = {
systemPackages = with pkgs; [
wget
curl
git
btop
ripgrep
vim
];
gnome.excludePackages = with pkgs; [ gnome.totem gnome-tour gnome.epiphany gnome.geary gnome-console ];
};
system.stateVersion = stateVersion;
programs.ssh.knownHosts = {
dmz = {
hostNames = ["*.dmz"];
publicKey = "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIAX2IhgHNxC6JTvLu9cej+iWuG+uJFMXn4AiRro9533x";
certAuthority = true;
};
hypervisors = {
hostNames = ["*.hyp"];
publicKey = "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIFzRkH3d/KVJQouswY/DMpenWbDFVOnI3Vut0xR0e1tb";
certAuthority = true;
};
};
security.sudo.extraConfig = ''
Defaults timestamp_timeout=30
'';
}